RSS-Feed
Follow on Twitter
Share on Facebook
Share on Facebook

Forum for M.A.R.S.

Important: Due to some problems, it’s currently difficult to create an account for this forum. If you want to have one, please send us (marscoreteam@googlemail.com) your desired user name and we’ll create an account for you. Sorry for this inconvenience!

Guest  

Welcome Guest, posting in this forum requires registration.

Pages: [1]
Topic: linux generic binaries error (Solved)
ShakaZ
Member
Posts: 1
[Solved] linux generic binaries error
on: November 13, 2011, 13:05

I’d like to report an issue with the latest generic binaries. There’s no readme available telling what to do run the game, but launching M.A.R.S. or marsshooter 64 results in errors.
shakaz:~$ /home/shakaz/mars_linux_0.7.4/M.A.R.S.
/home/shakaz/mars_linux_0.7.4/M.A.R.S.: line 20: ./marsshooter64: No such file or directory
shakaz:~$ /home/shakaz/mars_linux_0.7.4/marsshooter64
/home/shakaz/mars_linux_0.7.4/marsshooter64: error while loading shared libraries: libsfml-audio.so.2: cannot open shared object file: No such file or directory

Installing libsfml-audio1.6 doesn’t fix the issue.

The fix is described at the end of this email from Felix :

Note that runnig ./marsshooter64 directly requires to set your LD_LIBRARY_PATH manually. This is handled by the M.A.R.S.-script. I don’t know why it isn’t capable of finding the executable. Did you move it anywhere or is the self-containing directory left untouched?

If you keep trying to run ./marsshooter64, make sure to set your LD_LIBRARY_PATH correctly. Therefore it is necessary to install SFML-2.0 (not 1.6). Because this version of the library is not stable yet, I would recommend using the shared object files located in mars_linux_0.7.4/lib64/ .
The resulting execution command would be something like

LD_LIBRARY_PATH=”./lib64″:”$LD_LIBRARY_PATH” ./marsshooter64 -cfg ./ -data ./data/

Pages: [1]
WP Forum Server by VastHTML | LucidCrew
Version: 1.6.1 ; Page loaded in: 0.016 seconds.


Powered by WordPress, © 2010-2011 by Simon Schneegans and Felix Lauer (IMPRESSUM). Hosted on Sourceforge.